Category Archives: Alfresco

JBoss 7.1 and Alfresco SOAP API : conflict with XMLSEC 1.4.2 and Axis 1.4

If you need tu use Axis-1.4 and wss4j-1.5 with Jboss 7, you could have some runtime exceptions with xmlsec because wss4j-1.5 needs xmlsec-1.4.2 and Jboss has xmlsec-1.5.1 in its classpath and it won’t use your application jar but the one inside Jboss modules. Continue reading